$re = '/([а-яА-Я0-9.,]+(\s)(см|см.))/';
$str = 'черный анальный стимулятор с 4-мя шариками разными по диаметру. имеется удобная ручка для удерживания. шарики украшены пупырашками для большего удовольствия. материал изготовления tpr. диаметр шариков варьируется от 2 см 3 см. длина - 14 см. упаковка- блистер. страна изготовления- китай.
вибратор необычной формы с загнутой головкой. изготовлен из силикона, приятен на ощупь. имеет 12 режимов вибрации. режимы переключаются при помощи кнопки в основании игрушки. работает от usb кабеля. общая длина - 21 см, рабочая длина - 15,5 см, максимальный диаметр - 4 см. упаковка - коробка с блистером.
В некоторых строках есть: - диаметр - 4 см - диаметр 4 см - диаметр шариков варьируется от 2 см 3 см';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);