import re
regex = re.compile(r"([а-яА-Я0-9.,]+(\s)(см|см.))")
test_str = ("черный анальный стимулятор с 4-мя шариками разными по диаметру. имеется удобная ручка для удерживания. шарики украшены пупырашками для большего удовольствия. материал изготовления tpr. диаметр шариков варьируется от 2 см 3 см. длина - 14 см. упаковка- блистер. страна изготовления- китай.\n"
"вибратор необычной формы с загнутой головкой. изготовлен из силикона, приятен на ощупь. имеет 12 режимов вибрации. режимы переключаются при помощи кнопки в основании игрушки. работает от usb кабеля. общая длина - 21 см, рабочая длина - 15,5 см, максимальный диаметр - 4 см. упаковка - коробка с блистером.\n\n"
"В некоторых строках есть: - диаметр - 4 см - диаметр 4 см - диаметр шариков варьируется от 2 см 3 см")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")