#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(droits? d['\s]?entr\w*)[^,]{0,15}?(?P<g1>\d+[., ]?k?\d{0,3}) ?(€|eur\w*)(?!.{0,10}?fai)"
Local $sString = "Droit d‘entrée : 250 000€ -> ne marche pas" & @CRLF & _
"Droit d'entrée : 250 000€ -> marche"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")