use strict;
my $str = 'Droit d‘entrée : 250 000€ -> ne marche pas
Droit d\'entrée : 250 000€ -> marche';
my $regex = qr/(droits? d['\s]?entr\w*)[^,]{0,15}?(?P<g1>\d+[., ]?k?\d{0,3}) ?(€|eur\w*)(?!.{0,10}?fai)/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}