$re = '/(droits? d[\'\s]?entr\w*)[^,]{0,15}?(?P<g1>\d+[., ]?k?\d{0,3}) ?(€|eur\w*)(?!.{0,10}?fai)/mi';
$str = 'Droit d‘entrée : 250 000€ -> ne marche pas
Droit d\'entrée : 250 000€ -> marche';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);