const regex = /(?:'[^']*'|"[^"]*"|(\((?:[^()]++|(?1))*\))|[^'",])+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\'[^\']*\'|"[^"]*"|(\\((?:[^()]++|(?1))*\\))|[^\'",])+', 'gm')
const str = `lorem ipsum=123,delor='1,456',sit="123,456",amet=xxx(2,3),"consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua."`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}