import re
regex = re.compile(r"(?:'[^']*'|\"[^\"]*\"|(\((?:[^()]++|(?1))*\))|[^'\",])+", flags=re.MULTILINE)
test_str = "lorem ipsum=123,delor='1,456',sit=\"123,456\",amet=xxx(2,3),\"consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.\""
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")