re = /(?:'[^']*'|"[^"]*"|(\((?:[^()]++|(?1))*\))|[^'",])+/m
str = 'lorem ipsum=123,delor=\'1,456\',sit="123,456",amet=xxx(2,3),"consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua."'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end