using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"г\..+";
string input = @"1 августа 2016 г. 19.00
asdas";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}