using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^@ID_[A-Z0-9._-]*\*";
string input = @"@ID_111_I1_0.000_I2_0.00_I3_-0.999*
@ID_232_TS_09.0*";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}