const regex = /^@ID_[A-Z0-9._-]*\*/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^@ID_[A-Z0-9._-]*\\*', 'igm')
const str = `@ID_111_I1_0.000_I2_0.00_I3_-0.999*
@ID_232_TS_09.0*`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}