$re = '/^@ID_[A-Z0-9._-]*\*/im';
$str = '@ID_111_I1_0.000_I2_0.00_I3_-0.999*
@ID_232_TS_09.0*';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);