#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^ vlans )(?P<vlanrow>){([^}]*)}{0}.*vasgk.*\n"
Local $sString = "net route-domain /Common/0 {" & @CRLF & _
" id 0" & @CRLF & _
" vlans {" & @CRLF & _
" /vasgk/VASGK_L1_DMZ_INTERNA" & @CRLF & _
" /Common/http-tunnel" & @CRLF & _
" /Common/socks-tunnel" & @CRLF & _
" /Common/BIGIP-HA" & @CRLF & _
" /vasgk/VASGK_Transito_LB-FW" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")