using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^ vlans )(?P<vlanrow>){([^}]*)}{0}.*vasgk.*\n";
string input = @"net route-domain /Common/0 {
id 0
vlans {
/vasgk/VASGK_L1_DMZ_INTERNA
/Common/http-tunnel
/Common/socks-tunnel
/Common/BIGIP-HA
/vasgk/VASGK_Transito_LB-FW
}
}
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}