import re
regex = re.compile(r"(^ vlans )(?P<vlanrow>){([^}]*)}{0}.*vasgk.*\n", flags=re.MULTILINE)
test_str = ("net route-domain /Common/0 {\n"
" id 0\n"
" vlans {\n"
" /vasgk/VASGK_L1_DMZ_INTERNA\n"
" /Common/http-tunnel\n"
" /Common/socks-tunnel\n"
" /Common/BIGIP-HA\n"
" /vasgk/VASGK_Transito_LB-FW\n"
" }\n"
"}\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")