const regex = /(?<=역)역*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=역)역*', 'gm')
const str = `강남역역역`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);