use strict;
my $str = '강남역역역';
my $regex = qr/(?<=역)역*/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";