import re
regex = re.compile(r"(?<=역)역*", flags=re.MULTILINE)
test_str = "강남역역역"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)