#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)(^\d+(?!\.).*?)(?=^\s*\d)"
Local $sString = "7. On 6 March 2013, the Appeals Chamber filed the Decision on Victim " & @CRLF & _
"Participation, in which it decided that the victims “may, through their legal " & @CRLF & _
"" & @CRLF & _
"1" & @CRLF & _
" The full citation, including the ICC registration reference of all designations and abbreviations used in " & @CRLF & _
"this judgment are included in Annex 1. " & @CRLF & _
"2" & @CRLF & _
" A more detailed procedural history is set out in Annex 2 of this judgment. " & @CRLF & _
"ICC-01/04-02/12-271-Corr 07-04-2015 7/117 EK A" & @CRLF & _
"" & @CRLF & _
" 8/117 " & @CRLF & _
"representatives, participate in the present appeal proceedings for the purpose of " & @CRLF & _
"presenting their views and concerns in respect of their personal interests in the issues " & @CRLF & _
"on appeal”.3" & @CRLF & _
"" & @CRLF & _
"8. On 19 March 2013, the Prosecutor filed, confidentially, ex parte, available to the " & @CRLF & _
"Prosecutor and Mr Ngudjolo only, the Document in Support of the Appeal. The " & @CRLF & _
"Prosecutor filed a confidential redacted version of the Document in Support of the " & @CRLF & _
"Appeal on 22 March 2013, and a public redacted version of the Document in Support " & @CRLF & _
"of the Appeal on 3 April 2013. In the redacted version of the Document in Support of " & @CRLF & _
"the Appeal, the Prosecutor’s entire third ground of appeal was redacted. " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")