import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^\\d+(?!\\.).*?)(?=^\\s*\\d)";
final String string = "7. On 6 March 2013, the Appeals Chamber filed the Decision on Victim \n"
+ "Participation, in which it decided that the victims “may, through their legal \n\n"
+ "1\n"
+ " The full citation, including the ICC registration reference of all designations and abbreviations used in \n"
+ "this judgment are included in Annex 1. \n"
+ "2\n"
+ " A more detailed procedural history is set out in Annex 2 of this judgment. \n"
+ "ICC-01/04-02/12-271-Corr 07-04-2015 7/117 EK A\n\n"
+ " 8/117 \n"
+ "representatives, participate in the present appeal proceedings for the purpose of \n"
+ "presenting their views and concerns in respect of their personal interests in the issues \n"
+ "on appeal”.3\n\n"
+ "8. On 19 March 2013, the Prosecutor filed, confidentially, ex parte, available to the \n"
+ "Prosecutor and Mr Ngudjolo only, the Document in Support of the Appeal. The \n"
+ "Prosecutor filed a confidential redacted version of the Document in Support of the \n"
+ "Appeal on 22 March 2013, and a public redacted version of the Document in Support \n"
+ "of the Appeal on 3 April 2013. In the redacted version of the Document in Support of \n"
+ "the Appeal, the Prosecutor’s entire third ground of appeal was redacted. \n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}