# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^\d+(?!\.).*?)(?=^\s*\d)"
test_str = ("7. On 6 March 2013, the Appeals Chamber filed the Decision on Victim \n"
"Participation, in which it decided that the victims “may, through their legal \n\n"
"1\n"
" The full citation, including the ICC registration reference of all designations and abbreviations used in \n"
"this judgment are included in Annex 1. \n"
"2\n"
" A more detailed procedural history is set out in Annex 2 of this judgment. \n"
"ICC-01/04-02/12-271-Corr 07-04-2015 7/117 EK A\n\n"
" 8/117 \n"
"representatives, participate in the present appeal proceedings for the purpose of \n"
"presenting their views and concerns in respect of their personal interests in the issues \n"
"on appeal”.3\n\n"
"8. On 19 March 2013, the Prosecutor filed, confidentially, ex parte, available to the \n"
"Prosecutor and Mr Ngudjolo only, the Document in Support of the Appeal. The \n"
"Prosecutor filed a confidential redacted version of the Document in Support of the \n"
"Appeal on 22 March 2013, and a public redacted version of the Document in Support \n"
"of the Appeal on 3 April 2013. In the redacted version of the Document in Support of \n"
"the Appeal, the Prosecutor’s entire third ground of appeal was redacted. \n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.