using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)\b((\w{1,3})(-|\.{2,10})[\t ]?)+(\2\w{2,})";
string substitution = @"\2-\4";
string input = @"""Erm....yes. T..T...Thank you for that.""";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}