const regex = new RegExp('(?i)\\b((\\w{1,3})(-|\\.{2,10})[\\t ]?)+(\\2\\w{2,})', 'g')
const str = `"Erm....yes. T..T...Thank you for that."`;
const subst = `\2-\4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);