re = /(?i)\b((\w{1,3})(-|\.{2,10})[\t ]?)+(\2\w{2,})/
str = '"Erm....yes. T..T...Thank you for that."'
subst = '\\2-\\4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result