const regex = new RegExp('\\d{0,6}-?\\d{6,10}/\\d{4}', 'gm')
const str = `2300117015/2010
123-2300117015/2100
4567-2300117015/2100
2300117015/2100
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}