// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d{0,6}-?\d{6,10}/\d{4}").unwrap();
let string = "2300117015/2010
123-2300117015/2100
4567-2300117015/2100
2300117015/2100
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}