$re = '/\d{0,6}-?\d{6,10}/\d{4}/m';
$str = '2300117015/2010
123-2300117015/2100
4567-2300117015/2100
2300117015/2100
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);