package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:SYSTEM )?TEMPERATURE is (.*)$`)
var str = `SYSTEM TEMPERATURE is OK
TEMPERATURE is HIGH`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}