$re = '/^(?:SYSTEM )?TEMPERATURE is (.*)$/m';
$str = 'SYSTEM TEMPERATURE is OK
TEMPERATURE is HIGH';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);