#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d*(?:\.\d+)?)\s*x\s*(\d*(?:\.\d+)?)"
Local $sString = "2 x 3 kg PPG etc" & @CRLF & _
"bob 2 x 3 kg PPG etc" & @CRLF & _
"1.5x1.5kgPPGetcFred" & @CRLF & _
"BobFred1.5x1.5kgPPGetcFred" & @CRLF & _
"1.5 x 2.3 kg PPG Fred Bob" & @CRLF & _
"bob Fred 1.5 x 2.3 kg PPG Fred Bob" & @CRLF & _
"bob Fred .005 x 2.3 kg PPG Fred Bob" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")