re = /(\d*(?:\.\d+)?)\s*x\s*(\d*(?:\.\d+)?)/m
str = '2 x 3 kg PPG etc
bob 2 x 3 kg PPG etc
1.5x1.5kgPPGetcFred
BobFred1.5x1.5kgPPGetcFred
1.5 x 2.3 kg PPG Fred Bob
bob Fred 1.5 x 2.3 kg PPG Fred Bob
bob Fred .005 x 2.3 kg PPG Fred Bob
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end