# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d*(?:\.\d+)?)\s*x\s*(\d*(?:\.\d+)?)"
test_str = ("2 x 3 kg PPG etc\n"
"bob 2 x 3 kg PPG etc\n"
"1.5x1.5kgPPGetcFred\n"
"BobFred1.5x1.5kgPPGetcFred\n"
"1.5 x 2.3 kg PPG Fred Bob\n"
"bob Fred 1.5 x 2.3 kg PPG Fred Bob\n"
"bob Fred .005 x 2.3 kg PPG Fred Bob\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.