package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\/(\d+)\/`)
var str = `http://localhost/test/manage-users/1230/?value=1230
http://localhost/test/manage-users/1230/
http://localhost/test/manage-users/1230/test1/?value=1230
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}