re = /\/(\d+)\//
str = 'http://localhost/test/manage-users/1230/?value=1230
http://localhost/test/manage-users/1230/
http://localhost/test/manage-users/1230/test1/?value=1230
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end