$re = '/\/(\d+)\//';
$str = 'http://localhost/test/manage-users/1230/?value=1230
http://localhost/test/manage-users/1230/
http://localhost/test/manage-users/1230/test1/?value=1230
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);