#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<a(.*?)href=(((?!img).)*?)\"><\/a>"
Local $sString = "<a href="somelink.html"><img src="someimage.jpg"></a> " & @CRLF & _
"<a href="somelink.html"></a>" & @CRLF & _
"<a name="someanchor"></a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")