$re = '/<a(.*?)href=(((?!img).)*?)\"><\/a>/';
$str = '<a href="somelink.html"><img src="someimage.jpg"></a>
<a href="somelink.html"></a>
<a name="someanchor"></a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);