import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a(.*?)href=(((?!img).)*?)\\\"><\\/a>";
final String string = "<a href=\"somelink.html\"><img src=\"someimage.jpg\"></a> \n"
+ "<a href=\"somelink.html\"></a>\n"
+ "<a name=\"someanchor\"></a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}