package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)^[^A]*|(A.{6})`)
var str = `0000000
0000000
000A000
00AB000
AAAB000
ABBB000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}