const regex = /^[^A]*|(A.{6})/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^A]*|(A.{6})', 'gs')
const str = `0000000
0000000
000A000
00AB000
AAAB000
ABBB000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}