$re = '/^[^A]*|(A.{6})/s';
$str = '0000000
0000000
000A000
00AB000
AAAB000
ABBB000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);