using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"dtime\s+=\s\K[-+]?[0-9]*\.?[0-9]+([eE][-+]?[0-9]+)?";
string input = @"dtime = 0.004D0
dtime = 0.004D0
dtime = 0.004D0
dtime = 0.004D0";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}