$re = '/dtime\s+=\s\K[-+]?[0-9]*\.?[0-9]+([eE][-+]?[0-9]+)?/';
$str = 'dtime = 0.004D0
dtime = 0.004D0
dtime = 0.004D0
dtime = 0.004D0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);