import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "dtime\\s+=\\s\\K[-+]?[0-9]*\\.?[0-9]+([eE][-+]?[0-9]+)?";
final String string = "dtime = 0.004D0\n"
+ "dtime = 0.004D0\n"
+ "dtime = 0.004D0\n"
+ "dtime = 0.004D0";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}