#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)(" & @CRLF & _
" (?:" & @CRLF & _
" (?:" & @CRLF & _
" (?:25[0-5]|2[0-4]\d|[01]?\d\d?)\." & @CRLF & _
" (?:25[0-5]|2[0-4]\d|[01]?\d\d?)\." & @CRLF & _
" (?:25[0-5]|2[0-4]\d|[01]?\d\d?)\." & @CRLF & _
" (?:25[0-5]|2[0-4]\d|[01]?\d\d?)" & @CRLF & _
" |\*" & @CRLF & _
" )" & @CRLF & _
" )" & @CRLF & _
" (?:,\s*" & @CRLF & _
" (?:" & @CRLF & _
" (?:25[0-5]|2[0-4]\d|[01]?\d\d?)\." & @CRLF & _
" (?:25[0-5]|2[0-4]\d|[01]?\d\d?)\." & @CRLF & _
" (?:25[0-5]|2[0-4]\d|[01]?\d\d?)\." & @CRLF & _
" (?:25[0-5]|2[0-4]\d|[01]?\d\d?)" & @CRLF & _
" |\*)" & @CRLF & _
" )*" & @CRLF & _
")"
Local $sString = "192.168.1.1,192.56.3.23,189.35.2.2,198.23.45.56,198.168.1.255,*" & @CRLF & _
"" & @CRLF & _
"*, 192.168.1.1,192.56.3.23,189.35.2.2,198.23.45.56,198.168.1.255"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")