import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\n"
+ " (?:\n"
+ " (?:\n"
+ " (?:25[0-5]|2[0-4]\\d|[01]?\\d\\d?)\\.\n"
+ " (?:25[0-5]|2[0-4]\\d|[01]?\\d\\d?)\\.\n"
+ " (?:25[0-5]|2[0-4]\\d|[01]?\\d\\d?)\\.\n"
+ " (?:25[0-5]|2[0-4]\\d|[01]?\\d\\d?)\n"
+ " |\\*\n"
+ " )\n"
+ " )\n"
+ " (?:,\\s*\n"
+ " (?:\n"
+ " (?:25[0-5]|2[0-4]\\d|[01]?\\d\\d?)\\.\n"
+ " (?:25[0-5]|2[0-4]\\d|[01]?\\d\\d?)\\.\n"
+ " (?:25[0-5]|2[0-4]\\d|[01]?\\d\\d?)\\.\n"
+ " (?:25[0-5]|2[0-4]\\d|[01]?\\d\\d?)\n"
+ " |\\*)\n"
+ " )*\n"
+ ")";
final String string = "192.168.1.1,192.56.3.23,189.35.2.2,198.23.45.56,198.168.1.255,*\n\n"
+ "*, 192.168.1.1,192.56.3.23,189.35.2.2,198.23.45.56,198.168.1.255";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}