using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(
(?:
(?:
(?:25[0-5]|2[0-4]\d|[01]?\d\d?)\.
(?:25[0-5]|2[0-4]\d|[01]?\d\d?)\.
(?:25[0-5]|2[0-4]\d|[01]?\d\d?)\.
(?:25[0-5]|2[0-4]\d|[01]?\d\d?)
|\*
)
)
(?:,\s*
(?:
(?:25[0-5]|2[0-4]\d|[01]?\d\d?)\.
(?:25[0-5]|2[0-4]\d|[01]?\d\d?)\.
(?:25[0-5]|2[0-4]\d|[01]?\d\d?)\.
(?:25[0-5]|2[0-4]\d|[01]?\d\d?)
|\*)
)*
)";
string input = @"192.168.1.1,192.56.3.23,189.35.2.2,198.23.45.56,198.168.1.255,*
*, 192.168.1.1,192.56.3.23,189.35.2.2,198.23.45.56,198.168.1.255";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}