package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<div ([^=]+?)="([^"]+?)" ([^=]+?)="([^"]+?)" ([^>]+?)>`)
var str = `<div attr="Something" data-attr="test" data-foo>
<div attr="Something" data-attr="test" third-tag="Can't cap this" data-foo>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}