$re = '/<div ([^=]+?)="([^"]+?)" ([^=]+?)="([^"]+?)" ([^>]+?)>/';
$str = '<div attr="Something" data-attr="test" data-foo>
<div attr="Something" data-attr="test" third-tag="Can\'t cap this" data-foo>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);