// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<div ([^=]+?)="([^"]+?)" ([^=]+?)="([^"]+?)" ([^>]+?)>"#).unwrap();
let string = "<div attr=\"Something\" data-attr=\"test\" data-foo>
<div attr=\"Something\" data-attr=\"test\" third-tag=\"Can't cap this\" data-foo>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}